Welcome to Shadow Network

Seja bem-vindo ao nosso fórum, registre-se para poder interagir em nosso fórum

zykaimo

Members
  • Total de itens

    5
  • Registro em

  • Última visita

Reputação

4 Neutral

Sobre zykaimo

  • Rank
    Newbie
  1. [ESTUDO]

    ====================================================================== [Objetivo: Aplicação Cadastro de Alunos] [Estrutura de Dados: Arquivo] [Versão Modularizada] [Declaração de Tipos Globais] [Os tipos globais são visíveis em todos os módulos] [São declarados fora dos módulos] Treg_alunos = Registro matricula: inteiro nome: literal[30] endereco: literal[40] cidade: literal[15] telefone: literal[15] Fim-Registro Tarq_alunos = arquivo de Treg_alunos ====================================================================== [Módulo Principal] Algoritmo Cadastro_Alunos 1-[Início] 2-[Declaração de Variáveis Locais] reg_alunos : Treg_alunos opcao, matricula: inteiro cidade: literal[30] 3-[Processamento] Repita Escreva("1 - Cadastro de Alunos") Escreva("2 – Pesquisa por Matrícula") Escreva("3 – Pesquisa por Cidade") Escreva("4 – Relatório Geral") Escreva("5 - Sair") Escreva("Escolha Opção: ") Leia(opcao) Escolha (opcao) Caso opcao = 1 : cadastro() Caso opcao = 2 : Escreva(“Matricula:”) Leia(matricula) reg_alunos  Pesquisa_matricula(matricula) Se (reg_alunos.matricula <> 0) Entao Escreva(reg_alunos.nome) Escreva(reg_alunos.endereco) Escreva(reg_alunos.cidade) Escreva(reg_alunos.telefone) Senao Escreva(“Matrícula Inexistente!”) Fim-Se Caso opcao = 3 : Escreva(“Cidade:”) Leia(cidade) Pesquisa_cidade(cidade) Caso opcao = 4 : relatorio_geral() Caso opcao = 5 : Escreva(“Encerrando!”) Senao Escreva(“Opção Inválida!”) Fim-escolha Ate (opcao = 5) 4-[Fim] ====================================================================== [Módulo Cadastro] Procedimento cadastro() 1–[Início] 2-[Declaração de Variáveis Locais] reg_alunos : Treg_alunos arq_alunos : Tarq_alunos 3-[Processamento] Abra arquivo(arq_alunos) Leia(reg_alunos.matricula) Enquanto (reg_alunos.matricula > 0) Faca Repita Leia(reg_alunos.nome) Ate (reg_alunos.nome <> “”) Leia(reg_alunos.endereco) Leia(reg_alunos.cidade) Leia(reg_alunos.telefone) Escreva registro(arq_alunos, reg_alunos) Leia (reg_alunos.matricula) Fim_Enquanto Feche arquivo(arq_alunos) 4-[Fim] ====================================================================== [Módulo pesquisa_matricula] Funcao pesquisa_matricula(matricula: inteiro) : Treg_alunos 1–[Início] 2-[Declaração de Variáveis Locais] reg_alunos : Treg_alunos arq_alunos : Tarq_alunos 3-[Processamento] Abra arquivo(arq_alunos) Leia registro(arq_alunos, reg_alunos) Enquanto (nao EOF(arq_alunos)) E (reg_alunos.matricula <> matricula) Faca Leia registro(arq_alunos, reg_alunos) Fim-Enquanto Se (EOF(arq_alunos)= verdadeiro) [se fim de arquivo] Entao Reg_alunos.matricula  0 Fim-Se Feche arquivo(arq_alunos) Retorne reg_alunos 4-[Fim] ====================================================================== [Módulo pesquisa_cidade] Funcao pesquisa_cidade(cidade: literal[15]) 1–[Início] 2-[Declaração de Variáveis] reg_alunos : Treg_alunos arq_alunos : Tarq_alunos 3-[Processamento] Abra arquivo(arq_alunos) Leia registro(arq_alunos, reg_alunos) Enquanto (nao EOF(arq_alunos)) Faca Se (reg_alunos.cidade = cidade) Entao Escreva(reg_alunos.matricula) Escreva(reg_alunos.nome) Escreva(reg_alunos.endereco) Escreva(reg_alunos.telefone) Fim-Se Leia registro(arq_alunos, reg_alunos) Fim-Enquanto Feche arquivo(arq_alunos) 4-[Fim] ====================================================================== [Módulo relatorio_geral] Funcao relatorio_geral() 1–[Início] 2-[Declaração de Variáveis] reg_alunos : Treg_alunos arq_alunos : Tarq_alunos 3-[Processamento] Abra arquivo(arq_alunos) Leia registro(arq_alunos, reg_alunos) Enquanto (nao EOF(arq_alunos)) Faca Escreva(reg_alunos.matricula) Escreva(reg_alunos.nome) Escreva(reg_alunos.endereco) Escreva(reg_alunos.cidade) Escreva(reg_alunos.telefone) Leia registro(arq_alunos, reg_alunos) Fim-Enquanto Feche arquivo(arq_alunos) 4-[Fim]
  2. [TOOL]

    nice +rep
  3. Vá até a pasta onde está instalado o LoL. Siga o caminho por estas pastas: Abra o arquivo "lol" com o bloco de notas e troque esta linha de codigo: Por esta: Pronto. Só abrir o LOL que o chat ficará desconectado. Para desfazer o processo siga o mesmo caminho e apague o "." e salve. Obs.: Você só consiguirá digitar ingame(dentro de uma partida), ou seja não consegue ler ou enviar mensagens na champ select.

Shadow Network

Seja Bem-Vindo ao nosso fórum, construído com o intuito de compartilhar idéias e conhecimentos ao alcance de qualquer pessoa que tenha vontade de aprender.

Atencao

Em caso de bugs/erros no forum, entre em contato com algum membro da equipe.